HomeCLC software: Important notificationsIssues affecting only older versions of productsSome comparison operators in the Identify Candidate Variants tool do not work

2.21. Some comparison operators in the Identify Candidate Variants tool do not work

Issue description

Comparisons involving the following operators in the Identify Candidate Variants tool do not work and produce empty results:

  • >=  
  • <=
  • abs value > 
  • abs value <
  • abs value >= 
  • abs value <=

The History information of a data element output by this tool after using an affected comparison operator looks correct, but the comparison is not applied as expected.

Other operators are not affected by this problem.

 

Recommendation

Avoid setting up filters using the affected comparison operators in the Identify Candidate Variants tool on affected software. In most cases, a single operator equivalent can be specified instead. For example, the condition x>=15 could be specified as x>14 when filtering on integer values.

Affected software

  • CLC Genomics Workbench 10.1, 10.1.1, 10.1.2, 10.1.3, 11.0 and 11.0.1
  • Biomedical Genomics Workbench 4.1, 4.1.1, 4.1.2, 4.1.3, 5.0 and 5.0.1
  • CLC Genomics Server 9.1, 9.1.1, 9.1.2, 9.1.3, 10.1and 10.0.1

This issue affects the Identify Candidate Variants tool, whether run directly or via a workflow.

Ready-to-use workflows distributed with the Biomedical Genomics workbench or plugins that contain the Identify Candidate Variants tool are not affected as distributed, as the default configurations contain only working comparison operators.  If such a workflow is copied, and an Identify Candidate Variants element is edited to include an affected operator, then the newly created workflow will be affected when run on the software versions listed above.

 

 

 

Knowledge Tags

This page was: Helpful | Not Helpful